0

I have this error which causes me a lot of trouble with all of my crons for some of my website :

cURL error 28: connect() timed out!

The websites are stored on a shared servers i guess, how can I fix it ? Can't find something to help me on this point anywhere...

1

This error is most often related to the server configuration!

Contact your hosting company and ask the hosting support to check the following points:

  • The server is running a recent version of PHP and the cURL library.
  • Increase PHP Memory Limit settings.
  • Ask your web host if there is some limitation with wp-cron, or if loopback is disabled.
  • Ask your WebHost if there a firewall or security module (e.g. mod_security ) that could block outgoing cURL requests.
  • Your hosting company might need to switch DNS configuration to something like OpenDNS.
1
  • I've ended up with increasing to 512M my memory limit, but sometime still not enough, but yes, this is clearly a server config. thx Aug 10 '20 at 14:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.