1

I'm trying to implement WordPress Gutenberg editor outside of WordPress itself. Everything is working fine except having old classic block support and that requires window.wp.oldEditor to be set.

If you take a look at devtools console on post editing pages, window.wp.oldEditor is initiated with this: enter image description here

How can I initiate this variable by myself, out of the WordPress environment?

0

Ah ... Got it. It's not related to Gutenberg editor but WordPress core itself:

window.wp.editor is being initiated here with those methods:
https://github.com/WordPress/wordpress-develop/blob/9ed92faaca92f66ec9e2979c9d896ddab3e4e993/src/js/_enqueues/wp/editor/base.js

And then, window.wp.oldEditor = window.wp.editor:
https://github.com/WordPress/wordpress-develop/blob/5868743f1f2b05c93642c9eebf89cb7f6610d6df/src/wp-includes/script-loader.php#L369

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.