0

I have had my WordPress site running more or less smoothly for a few years. Recently I noticed that the footer disappeared from the entire site. I did a little digging around only to discover that everything from the footer was lying within the 'Inactive Widgets' section (under Dashboard > Appearance > Widgets).

So I dragged everything back in place and checked the website – everything was fine. The next day I checked, the footer was gone again. I did the same thing again and this time returned to check the website a few minutes later. Within minutes (maybe ~5 or so) I noticed that the footer widgets were being removed in parts, i.e. Footers 3 and 4 had already gone as well as the sidebar, but footers 1 and 2 were still there. I refreshed the page and found that now footer 2 had also disappeared. Then soon the entire thing was gone again.

It's been going on for a few weeks now and I can't find help anywhere. There's no point in restoring the widgets because they go away within few minutes anyway. Does anyone have any idea what's going on?

One of the latest things I've done is deactivated all the plugins and then reactivated again. Previously I've tried disabling one of the big plugins for a couple of days only to find no success.

If it helps, here are the website specs:

  • WordPress version: 5.4.2–en_GB (latest)
  • Theme: Bellevue Version: 3.2.8 (running on child theme)
  • Page builder: Elementor Version 2.9.14 (free/included with theme)
  • Hosting: GoDaddy Linux cPanel
  • PHP version: 7.4

Website: www.itravellershostel.com

I'm at wits end now. Any help would be greatly appreciated!

Cheers, Ashish

Screenshot of the footer area

  • I'm wondering if this is an issue with your theme - have you reached out to the Bellevue support team? – Tony Djukic Jul 23 at 15:57
  • I haven't yet. I guess I should... – Ashish V Jul 23 at 17:07
0

Sorry for posting this as an answer, but can't add comments yet.

Can you go to WP Dashboard -> Tools -> Health Check and see if there is anything useful available there?

| improve this answer | |
  • The Site Health status shows as 'Good'. There are 3 recommended improvements given at the bottom: • You should remove inactive plugins (Security) • One or more recommended modules are missing (Performance) > The optional module, zip, is not installed, or has been disabled. • An error occurred while checking whether your site can be found by search engines – Ashish V Jul 22 at 5:27
  • Try to install missing modules. Though marked as option, zip is used widely by WordPress. This might not resolve your issue with disappearing footer widgets though, but will keep your site healthy in general. Also consider paying attention to search engines issue. – Desert Fox Jul 22 at 12:02
  • Back to your original issue, try to remember which plugins or themes you updated right before you noticed those. Try to disable those and see if it helps. If not, enable WP debug log and see if there's anything useful displayed on the log. – Desert Fox Jul 22 at 12:08
  • I've installed the missing zip module and am looking into the SEO bit now. As for plugins – I've tried disabling and then reenabling all plugins but that did not help. I guess I will try disabling all plugins and leave it as is for a couple of hours. If it's one of the plugins, it'll show. Pinpointing a specific plugin isn't possible. – Ashish V Jul 23 at 17:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.