1

I have a custom WordPress theme I've developed and have included the following lines in my wp-config.php in hopes to automate plugin and core updates:

define( 'WP_AUTO_UPDATE_CORE', true );
add_filter( 'auto_update_plugin', '__return_true' );
add_filter( 'auto_update_theme', '__return_true' );

I've let it process for about a week now but the plugins that have available updates aren't updating. Do I need to include anything additional in my theme's functions.php to initiate these automatic updates?

Additionally, does anyone know how quickly these updates take place when a new plugin or core update is released? Or is it essentially instantaneous?

Thanks for your help!

1

There's a page here about Configuring Automatic Background Updates.

It says specifically not to put the filters in wp-config.php, so you should definitely move those to functions.php; they were probably not registered if added in wp-config.php so that explains why you didn't get plugin or theme updates, but core updates should have worked. Only constants like define( 'WP_AUTO_UPDATE_CORE', true ); should go in wp-config.php.

It's not extremely clear from docs in the codex when or how these auto updates get run, but this article says they're triggered from WP-Cron at 7a.m. and 7pm local time. So you should definitely expect an update to happen within 12-24 hours at the most. Note this is dependent on having enough traffic to your site to trigger WP-Cron.

Docs say that core updates trigger a notification email however plugin and theme updates do not.

Does that help?

| improve this answer | |
  • This is incredibly helpful! I've moved the two lines add_filter( 'auto_update_plugin', '__return_true' ); add_filter( 'auto_update_theme', '__return_true' ); to functions.php and kept the following line in wp-config.php define( 'WP_AUTO_UPDATE_CORE', true ); I will report back in the next few days to see if this changes anything. Thanks so much for your help! 'test' – Ben Stewart Jul 13 at 12:10
  • So it appears as though things haven't really changed with moving the lines to functions.php. I have three available plugin updates currently, one released 3 days ago, one of them 1 day ago and one of them 22 hours ago. Any thoughts on why these wouldn't be updating? Thanks for your help! – Ben Stewart Jul 16 at 16:35
  • Ah, bummer. There are a lot of results for auto updating not working searches. This one has some specific things to check that might be affecting it: wordpress.stackexchange.com/questions/236282/… – mozboz Jul 16 at 17:29
  • Unfortunately it appears as though "Background Update Tester" isn't compatible with the latest version of WordPress, even to the point that the plugin settings panel doesn't appear in the WP dashboard. Doees anyone have any insight as to how to tell if the autoupdate functionality is having any conflicts; specifically the three parameters that "Background Update Tester" checked for: 1) My WordPress install can communicate with WordPress.org securely, 2) No detection of version control systems and 3) If my installation of WordPress prompts for FTP credentials to perform updates. Thanks again! – Ben Stewart Jul 17 at 20:47
  • 1
    So I just noticed in my wp-config.php there was line that read define('AUTOMATIC_UPDATER_DISABLED', true);, which I have updated to false. There was a note that this was placed here during the original Installatron installation. With that said, I've added the following lines to my active theme's functions.php add_filter( 'auto_update_core', '__return_true' ); add_filter( 'auto_update_plugin', '__return_true' ); add_filter( 'auto_update_theme', '__return_true' ); and, for consistency, removed define( 'WP_AUTO_UPDATE_CORE', true ); from wp-config.php. Will update this thread soon! – Ben Stewart Aug 10 at 20:53
1

Just confirming that I did indeed solve the issue! The problem was the following line within wp-config.php that was put in place by Installatron:

define('AUTOMATIC_UPDATER_DISABLED', true);

Once I updated this to "false", and added the following lines to functions.php, the automatic updates worked perfect:

add_filter( 'auto_update_core', '__return_true' );
add_filter( 'auto_update_plugin', '__return_true' );
add_filter( 'auto_update_theme', '__return_true' );

Hope this helps others with similar problems!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.