So I did an auto update to WP 3.3 and got a screen telling me there was a DB upgrade needed. I hit continue and it said the upgrade was a success. I hit continue again and the same screen popped up telling me the DB needed upgrading... repeat cycle.

Then I changed the DB version in version.php (18226) to match what was in the database under the options table for DB version (19470). This allows me to access the backend, but nothing will update. Can't update any post or pages. It says the page is updated, but it never actually does...

I have read and tried all of these solutions:

Site stuck in "Database Update Required" loop



Any suggestions?



2 Answers 2


I've had this issue before. I stumbled on a really old article from Mark Jaquith on forcing an update. The plugin I'm linking to was originally made to update from 1.5.x to 2.0.x. I was in a bind so I gave it a shot. I did have recent back-ups for my DB so I wasn't too worried. Luckily the plugin still worked. What version does it does it currently show your using?


I fixed the issue by changing the DB credentials in wp-config.php. Apparently, they were wrong...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.