0

Since a few days, After I migrated my wordpress site from a host to another, my plugins page is super slow !

When I click to see all plugins, or to install a plugin, I get one time out of two a error 500. It clears when I refresh a second time the page.

I disabled all plugins, and it goes away for a few minutes, then comeback ! It seems to always comeback after some time of smooth / normal operation. So the behaviour is very inconsistent.

I suspect the migration to have cause some cause of probleme, as the old site didnt have a SSL certificate and the new one has. To fix the mixed content I've updated links in DB and installed a plugin to fixe the mixed content (SSL Insecure content).

The thing is that I cant seem to find the exact cause or to solve the issue. Does anyone encountered this issue or have any tips for me ?

Thanks in advance !

4
  • The SSL certificate shouldn't make any difference really. It's possible the problem is generating a short-lived transient: can you check your wp_options for any transient values that get generated when the page fails? Are there are any error logs in your server or PHP error logs for the 500 errors? Your host is a regular VM or similar - you're not e.g. trying to host the WordPress admin site on an Azure or AWS function (where the backing VM might spin down when idle?) Is your host a WordPress-specific host, i.e. might they know anything about this? – Rup Jun 15 '20 at 8:09
  • Hello, thanks for your help ! I checked and the wp-options table seems clean and no transiant values are generated when the errors occure, I'm on a regular VPS from OVH, the VPS is not dedicated to Wordpress but to webhosting in general, adn Wordpress is of course officialy supported... The support from the host tells me the probleme is most likely to come from my wordpress isntalation then from them, as every other page works... – Elliot Jun 17 '20 at 8:00
  • These are the two errors that I get from the logs over and over from the plugin page : - [Mon Jun 15 09:41:51 2020] [error] [client 109.7.213.208] [host blueorangegames.eu] AH10149: FastCGI: incomplete headers (0 bytes) received from server "/homez.962/dkjqknb/blueorange/wp-admin/update.php", referer: blueorangegames.eu/wp-admin/… – Elliot Jun 17 '20 at 8:06
  • - [Mon Jun 15 09:41:51 2020] [error] [client 109.7.213.208] [host blueorangegames.eu] AH10141: FastCGI: comm with server "/homez.962/dkjqknb/blueorange/wp-admin/update.php" aborted: idle timeout (160 sec), referer: blueorangegames.eu/wp-admin/… – Elliot Jun 17 '20 at 8:08
1

The Query Monitor plugin will often highlight issues and is definitely worth a look.

3
  • Thanks for the advice ! I'm installing it and hope to have insights to resolve the problem from it ! – Elliot Jun 17 '20 at 8:47
  • So I tried to use Query Monitor, but the thing is, when the extension page does not work, I do not see any result in Query Monitor as I get the error 500, and when the page loads fine, their is no problem detected by the plugin :/ – Elliot Jun 19 '20 at 7:24
  • From seeing your other comments, it sounds like it might be an issue with the hosting provider. One way of debugging might be to download MAMP and set up your site on your local computer and see if the error still occurs. – Neil Scott Jun 19 '20 at 8:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.