0

I know this question might be a repeat or duplicate of another post. I've been getting this error after shortly migrating the domain from http to https.

I've been following multiple questions and answers like this one right here but none of them seem to work.

Solutions i've tried: -> disable all plugins and enable them again -> change .htaccess file to the default wordpress -> change permalink structure to the default one again.

None of the above solutions worked for me now, although they worked in the past for a different website.

All pages give me 404 document not found in the server except the homepage.

thanks in advance!

EDIT:

The problem does not happen if i use the default permalink structure and if use the following code in the wp-config:

define('WP_HOME', 'https://websiteurl'); 
define('WP_SITEURL', 'https://websiteurl');

//define('WP_DEBUG', true);
define('CONCATENATE_SCRIPTS', false);
1

what did you do to migrate from http -> https? Did you just change the setting in wordpress Settings -> General?

| improve this answer | |
  • So Basically , the devops of my team updated the http certificate and moved it to a new domain, but under the same url. The problem has been fixed but only if the wordpress permalink structure is the default one, i've tried to use the /%category%/%postname% and it doesn't work :( – Pedro Ferreira Jun 2 at 16:02
  • See the new edit please! – Pedro Ferreira Jun 2 at 16:03
0

Fixed it by changing the website url in the database on the table wp_options

Seems like it didn't change even after i change the url in the backend, i had to change it manually.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.