0

Yesterday I was trying to change just one option of the WP Autoptimize plugin (inline and defer css) to avoid it render blocking. This was the process of it:

  1. I extracted the critical CSS with an online tool and added it to the plugin.
  2. Activated the option and then saved and emptied both Autoptimize (AO) cache and WP Super Cache (another complementary cache plugin).
  3. Activated development mode and purged everything in Cloudflare panel.
  4. All worked perfectly so I left the new AO option on.
  5. A day later my site has stopped working, returning a Cloudflare 504 timeout frontend and backend.
  6. Activating dev. mode and purging cache doesn’t work. The site only gets back to normal if I pause Cloudflare on the site.

After that, I deactivated “inline and defer option” in AO but Cloudflare cache is still broken. Since then there’s no way to purge the cache or fix it activating dev mode I can’t activate Cloudflare again without breaking my site. I must leave it paused.

I tried to fix this with Namecheap support and all is well on their end, the 504 is not caused by their servers. In Cloudflare forums they only referred me to this article. But none of the reasons for the 5xx error it gives is causing my situation.

Here's the original thread in Cloudflare for reference.

Any help on how to purge the cache would be appreciated.

Also if anyone knows how could the option “inline and defer css” break my entire site. I have activated it other times before having Cloudflare and the website loaded although with messed up CSS. With Cloudflare it should be not much different. I’m completely flabbergasted.

Thanks for your attention.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.