1

When visiting wp-admin at the link http://ec2-3-16-54-250.us-east-2.compute.amazonaws.com/wp-admin, I get the below URL

http://ec2-3-16-54-250.us-east-2.compute.amazonaws.com/wp-admin/ec2-3-16-54-250.us-east-2.compute.amazonaws.com/wp-login.php?redirect_to=http%3A%2F%2Fec2-3-16-54-250.us-east-2.compute.amazonaws.com%2Fwp-admin%2F&reauth=1

I am coming from a direct database transfer from localhost to server.

I went into wp-options and changed the option_value in wp_options to reflect that of the current live. See below.

   option_id: 1
 option_name: siteurl
option_value: ec2-3-16-54-250.us-east-2.compute.amazonaws.com
    autoload: yes

*************************** 2. row ***************************

   option_id: 2
 option_name: home
option_value: ec2-3-16-54-250.us-east-2.compute.amazonaws.com
    autoload: yes

I just replaced the localhost values, though it seems I've done something incorrectly. I have not installed any url altering plugins or htaccess files, it is a relatively fresh AWS EC2 instance.

I see a lot of issues out there of people failing to reach the wp-admin link, but not this on specifically.

Can you please help?

3 Answers 3

0

When moving / cloning a site to a new URL, just changing the wp-options option_value is not enough.

The proper way of doing this is to use a wordpress site cloning plugin (lot's of free good ones), such as Duplicator. Do a proper archive and install the site on AWS. It should take care of all the URL issues, and is much faster than you manually trying to fix your install (and may have miss something which will come back at you down the road).

Here is the plugin: https://en-ca.wordpress.org/plugins/duplicator/

0

That’s odd!

Double-check you’ve not accidentally pasted the url twice into the database options table rows (it seems to be duplicated).

Check .htaccess for anything that might cause an odd redirect/rewrite.

You’re doing well .... keep going. AWS deployments are always tricky. But like you I’d rather do it manually - I don’t trust “magic” plugins.

0

When I migrate websites from local to production I sometimes bump in similar situations, my solution is to define the siteurl and home in the wp-config/functions.php

This way it's absolute and you don't rely on database updates.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.