0

I set up a virtual machine, say machine A, running bitnami and wordpress and configured the SSL certificates for a domain. I then upgraded my code to NodeJS and got a new virtual machine, say machine B, with a different IP. I configured SSL certificates and all is well with machine B. I want to access machine A to view the previous website on Wordpress.

When I enter machine A's IP on a browser, it still redirects to the domain of machine B. I deleted the SSL certificates from /opt/bitnami/letsencrypt/certificates, and recovered the bitnami configuration:

sudo mv /opt/bitnami/apache2/conf/bitnami/bitnami.conf /opt/bitnami/apache2/conf/bitnami/bitnami.conf.letsencrypt
sudo mv /opt/bitnami/apache2/conf/bitnami/bitnami.conf.back.202003211640 /opt/bitnami/apache2/conf/bitnami/bitnami.conf
sudo /opt/bitnami/ctlscript.sh restart apache

When I visit <machine A's IP>/wp-admin, I see:

This connection is not private
This website may be impersonating  to steal your personal or financial information. You should go back to the previous page.
Safari warns you when a website has a certificate that is invalid. This may happen if the website is misconfigured or an attacker has compromised your connection. To learn more, you can view the certificate.

I installed a new certificate with these directions. That certificate does not update on my browser, which probably means that the server is not using the Bitnami certificate configuration.

I found that /opt/bitnami/apache2/scripts/ctl.sh contained:

HTTPD="/opt/bitnami/apache2/bin/httpd -f /opt/bitnami/apache2/conf/httpd.conf"

and that /opt/bitnami/apache2/conf/httpd.conf contained:

ServerAdmin you@example.com
...
ServerName <website-domain>:80

I changed that second line to have the VM's IP address, and then the Apache server does not launch, even though it says Syntax OK. I decided to stop before causing any more damage. I undid that change, and the server still does not launch.

Rolling back the earlier changes:

sudo mv /opt/bitnami/apache2/conf/bitnami/bitnami.conf /opt/bitnami/apache2/conf/bitnami/bitnami.conf.back.202003211640
sudo mv /opt/bitnami/apache2/conf/bitnami/bitnami.conf.letsencrypt /opt/bitnami/apache2/conf/bitnami/bitnami.conf

now breaks the server startup because I deleted the SSL certificates.

I don't have snapshots of the virtual machine.

How can I access the Wordpress website and its content?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.