0

The REST API request failed due to an error.

Error: [] cURL error 60: SSL certificate problem: certificate has expired

  • That's a problem with the service you're calling. You should ask them to fix it. You can also turn off certificate validation in php-curl as a temporary work-around, but that's not a good idea in general: you should get the API provider to get a new certificate. – Rup Mar 23 at 10:11
  • Oh, you mentioned Gutenberg in a past revision: is this your own REST API for a self-hosted WordPress? You should set your server up with a valid SSL certificate, e.g. you can get free certificates from letsencrypt.org. Or I assume you have a self-signed certificate that's been autogenerated on your server? You could add that to the central CA list on your server so that it trusts it. But a real widely-accepted certificate would be better. – Rup Mar 23 at 10:20
  • That means if i buy a ssl certificat it would solve the problem – anish bhattrai Mar 23 at 11:19
  • If this is your own server, yes. But there are other options e.g. free certificates, change whatever REST calls this is to use HTTP not HTTPS, set up whichever client this is to trust the server's self-signed certificate, etc. – Rup Mar 23 at 11:20
  • I've just searched for "The REST API request failed due to an error" and it's on the site health dashboard: is this only a problem on the health dashboard, and everything else on the site is working? In which case you can might get away with just leaving this: there's a risk other parts of the site will use the same API mechanism and fail, but if you've tested everything and haven't seen that then it might just be OK. – Rup Mar 23 at 11:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.