1

I'm new to WordPress and I obtained a package from a third party in .zip format. When I upload it on my Wordpress system, I see

The package could not be installed. No valid plugins were found.

I reinstalled Wordpress from scratch (bitnami and AWS), and I still get the same error.

This page suggests that it is a problem with SSL, so I have checked that and it all seems in order.

How can I fix it?

  • 2
    You should probably talk to Yootheme directly. If you can you should try and work out what URL their code is trying to call, e.g. by finding it in their code and tracing the URL out to error_log(), and then try that URL yourself both from another environment such as your desktop and from a shell on the server itself e.g. using curl - that way you'll be able to narrow down if the problem is at your end or theirs. – Rup Mar 21 at 19:33
  • 1
    But - if you're confident it's not an SSL problem - without either the code or access to their server I'm not sure we can help you. – Rup Mar 21 at 19:34
  • 1
    Rup is right, you need to contact the vendor for support, 3rd party theme/plugin support is offtopic here – Tom J Nowell Mar 21 at 22:18
  • 1
    You've solved this? Great. If it isn't something specific to Yootheme then yes, click the 'flag' link and ask for it to be reopened. I'm not sure how a plugin would fix a "not a valid JSON response" error though? – Rup Mar 22 at 8:16
  • 1
    You're just uploading a zipped plugin? Where do you get the "not a valid JSON response" error? – Rup Mar 23 at 8:35

Browse other questions tagged or ask your own question.