0

I have problem with WordpPress 5.3.2. My theme is Glob (free version). I have tried everything but nothing is happening. I have the error only in admin but it make me very stressed. I want your help.

Warning: call_user_func_array() expects parameter 1 to be a valid callback, function 'my_custom_excerpt_length' not found or invalid function name in .../wp-includes/class-wp-hook.php on line 288

Warning: call_user_func_array() expects parameter 1 to be a valid callback, function 'my_custom_excerpt_more' not found or invalid function name in .../wp-includes/class-wp-hook.php on line 288

3
  • Hello Antonio, welcome to WordPress Development. The warning message is very specific that, the mentioned (hooked) function named my_custom_excerpt_more is not found in your code. If you know what this is, you can create one, or you can remove the hook where the function is hooked, and that will resolve the issue. But please be informed that, question specific to third party products (like your theme) is off-topic here in this platform. You can read FAQ on how to ask questions. Mar 1, 2020 at 9:21
  • I'm sorry if I asked for prohibited information. I am a new user and my english sucks. I am not a programmer and it is difficult for me to modify the code. I can only say that the error appeared after the wordpress update. With version 5.3.1 it worked fine. I will make attempts to remove the code. I hope the site doesn't explode. :D Thanks for now!!! Mar 1, 2020 at 9:52
  • While you resolve the issue, in the interim you can downgrade WordPress back to WordPress 5.3.1 Mar 1, 2020 at 11:31

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.