0

After putting up a recent dev site, I'm met with a very annoying 403 error I can't figure out. It's only an issue with non-WP core widgets (for example, Recent Posts Extended) and I can't add scripts through the customizer (eg, adding a Font Awesome kit). They just throw admin-ajax.php 403 errors.

Failed to load resource: the server responded with a status of 403 () -- admin.ajax.php:1

It's a brand new dev site, brand new WP install and we don't have ANY caching running on the site or the server. And of course, the first thing I tried was disabling all plugins. We run Genesis, but I've never seen this issue so persistent before without any obvious implications of what it's being caused by.

My boss can do it just fine, so I'm 98% positive it's a permissions issue but all of the permissions appear to be just fine (644 and 755). I've switched browsers and tried on other machines. I even cleared my own cache and DNS, even though I'm pretty sure it can't be a local issue.

I've looked things up, scoured the StackExchange forums; I can't find any solutions. I'm positively stumped here. Any assistance or troubleshooting ideas would be awesome. Thanks!

4
  • 1
    If your boss can make the requests, but you get 403 responses, then it's not a file permissions error, ( also we aren't a discussion forum, think of us as a wiki of questions, if you have a question you look it up and find the answer, otherwise you run the risk of starting discussions and getting your question closed offtopic )
    – Tom J Nowell
    Feb 4, 2020 at 20:08
  • 1
    FIGURED IT OUT: A Wordfence firewall issue on the main domain. @TomJNowell I know how StackExchange works. I DID look it up before posting and checked all the relevant threads - nothing was useful. So I asked my own question so others would have another potential solution to navigate if they were dealing with my same issue. Also, the WordPress Codex is a Wiki - this IS a forum. Otherwise, the button would say "Contribute" and not "Ask Question" as it does. Maybe don't be so patronizing?
    – Vanderbeam
    Feb 4, 2020 at 20:57
  • You can ask on the meta site if you want to discuss the site itself, see here wordpress.stackexchange.com/help/how-to-ask, just note that discussions on the main site are offtopic
    – Tom J Nowell
    Feb 4, 2020 at 21:07
  • Thanks @Vanderbeam, I forgot I had Wordfence installed on the main domain also. Perhaps post this as an answer to the question?
    – clayRay
    Jun 17, 2022 at 5:50

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.