0

I am having some issues determining the solution to this problem below. The website was sent to our team to fix.

Turned on error reporting in wp-config.php:
define('WP_DEBUG', true);

WordPress version: 5.3.2
PHP version: 7.2

WordPress Theme: Grow Pro

Fatal error: Uncaught Error: Class 'WP_Block_Styles_Registry' not 
found in /home/website/public_html/clientsite.com/wp-includes/script- 
loader.php:2902 Stack trace: #0 
/home/website/public_html/clientsite.com/wp-includes/class-wp- 
hook.php(288): enqueue_block_styles_assets('') #1 
/home/website/public_html/clientsite.com/wp-includes/class-wp- 
hook.php(312): WP_Hook->apply_filters(NULL, Array) #2 
/home/website/public_html/clientsite.com/wp-includes/plugin.php(478): 
WP_Hook->do_action(Array) #3 
/home/website/public_html/clientsite.com/wp-includes/script- 
loader.php(2856): do_action('enqueue_block_a...') #4 
/home/website/public_html/clientsite.com/wp-includes/class-wp- 
hook.php(288): wp_common_block_scripts_and_styles('') #5 
/home/website/public_html/clientsite.com/wp-includes/class-wp- 
hook.php(312): WP_Hook->apply_filters(NULL, Array) #6 
/home/website/public_html/clientsite.com/wp-includes/plugin.php(478): 
WP_Hook->do_action(Array) #7 /home/website/public_html/ir in 
/home/website/public_html/clientsite.com/wp-includes/script-loader.php 
on line 2902

There has been a critical error on your website.

Learn more about debugging in WordPress.


For privacy reasons, I wouldn't be sharing the live website link.

Any help with resolving these errors would be greatly appreciated.

Thank you in advance,
Nick Hiebert

4
  • Did you recently update WP? Sounds like this issue.
    – kero
    Jan 30, 2020 at 15:59
  • @kero sounded very similar. Managed to figure out the issue. Jan 30, 2020 at 16:21
  • This may help you. wphuntrz.com/d/…
    – jogesh_pi
    Jan 31, 2020 at 5:09
  • @jogesh_pi we're looking at the issues with the WordPress update as we speak. So I'll report back what ends up being the fix. Feb 12, 2020 at 15:02

1 Answer 1

0

From this post on WordPress.org "Fixing fatal error after 5.30 update", it mentions issues with Gutenberg.

I installed the Glutenberg plugin and the website is now loading properly.

Hope this comes to use for the future for anyone else!

2
  • Watch out, I don't believe you actually fixed your problem and just avoided the error message. The post you mention there is mine, and I did not have the message Class 'WP_Block_Styles_Registry' not found but another one. Your error probably comes from an incomplete update. Other stuff may break until you fix this!
    – kero
    Jan 30, 2020 at 17:35
  • @kero Sounds good, it is likely a WordPress update issue. I'll report back the actual fix to this once it's resolved. Feb 12, 2020 at 15:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.