1

I have a folder in my site's public_html directory called /connect. The folder is causing the page sitename.com/connect to access a parent index page instead of the Wordpress page set up.

Deleting this folder solves the problem, but this folder keeps getting added daily by my autoSSL program. It was due to a connect.sitename.com subdomain being set up, but even after removing that from the DNS, it is still being added daily.

Is there anything that I can do to the htaccess file, or anything else to ignore that folder and use the Wordpress page I've set up?

There is no way that I can change the URL, the client has sent out print media with the URL on it.

  • You can move all files related to your Wordpress website to an other folder and edit the domain settings pointing to the new folder. – Luckyfella Jan 14 at 20:02
  • Just did that following this guide, but it didn't solve the issue. Site is still reachable, but the /connect page is still being overwritten with the folder in the public_html directory – Paul Elrich Jan 14 at 20:11
  • The new folder should not be nested in any way inside the connect folder. If you edit the domain settings in your hosting panel to the new folder you can‘t still have the same issue. – Luckyfella Jan 14 at 20:18
1

Ordinarily, requests for physical directories (and files) are not routed to WordPress. You could make an exception for this one folder (or URL) and specifically rewrite requests for /connect to index.php (the WordPress front-controller).

Try the following before the # BEGIN WordPress section:

# Override directory
RewriteRule ^connect index.php [L]

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.