0

I am using Wordpress to construct my site, this issue is very new and no plugins seem to be causing it.

The fonts do not load properly ONLY in the desktop version of Safari and Firefox

The preferred view can be seen below in Chrome and mobile devices: chrome

The unpreferred view can be seen below in the Desktop version of Safari and Firefox: safari/firefox

See for yourself: www.TattiniBoots.com

Any help is appreciated

  • Can you be more specific? At first glance the only bit that looks wrong to me (Windows Chrome and Firefox, comparing to iPhone Safari) "WELCOME TO TATTINI BOOTS Premium Italian English Riding Dressage Boots" and that doesn't look like in a font you're loading. – Rup Jan 13 '20 at 9:43
  • However there are different ways of embedding fonts using different file formats, so if it does vary between browsers it might be because the browsers want fonts in different formats. So it might be worth checking exactly what the problem browsers are trying to load, and that the font embedding CSS is set up correctly for that format by whatever mechanism you're using (plugin? theme?) – Rup Jan 13 '20 at 9:44
  • Images have been added to demonstrate what is preferred/unpreferred – user2592356 Jan 13 '20 at 16:32
0

It's because you're only specifying font-family: Marcellus; inside a @media (max-width: 600px) {}, and your desktop browsers are wider than that. Everything else is using the default stack of "Helvetica Neue, Helvetica, Arial".

  • I'm not sure why this is working for you in Chrome, though. It doesn't for me. And this isn't particularly a WordPress issue: even if the autoptimize plugin was breaking this for you somehow (and you say it's not a plugin) you'd do better asking them for help with that. – Rup Jan 13 '20 at 16:52
  • Can you verify if it working for you in chrome now? The concern is that this is a VERY new issue and never took place as of about a week ago. Only 3 new plugins were installed and de-activating those have NO effect – user2592356 Jan 15 '20 at 4:37
  • No, looks the same to me: Helvetica normally and Marcellus only if I tell the browser to pretend to be a mobile device. I don't know if this would be a plugin or not: I'd guess this was set up by hand in the theme or child theme stylesheet? – Rup Jan 15 '20 at 6:16
  • Its confusing because this issue has never occurred before – user2592356 Jan 15 '20 at 19:22
  • Can you let me know if it working for you now? – user2592356 Jan 15 '20 at 19:23
0

This was simply a plugin issue with Product Suggestions for WooCommerce: https://wordpress.org/plugins/cart-products-suggestions-for-woocommerce/

In the instance that a new issue occurs that was not taking place prior to installation, it can almost always be attributed to a plugin issue

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.