2

I don't know enough wordpress to actually be able to find the correct wording to get any real information on my problem.

Someone asked me to set up a simple news system in a already running website, so everything is already working as pure html all around.

I didn't really want to obstruct the root directory of the website so I installed WordPress in a /wp/ folder and I managed to setup the news fine but my URLs display that www.xxx.com/wp/news_name/ which I don't want.

I would like some guidance as to what all this is referred as.

I went to the dashboard main options and changed the paths WordPress Address: www.mysite.com/wp/ Site Address: www.mysite.com/ or www.mysite.com/news/

or just went to the permalink page and setup the custom path as: www.mysite.com/news/%post_name%/

but any of this returns a 404.

My guess is that there is something to do with .htaccess files but I got no luck tempering with it the way I am used to.

Thanks for any info of the subject and sorry if it is a overly asked problem but I can't seem to find my exact problem using the wording I know,

2

It's a bit of a trick to get a Wordpress site working within a framework of a non-Wordpress (html only) site in a fully-integrated way (though it can be done!). To keep things simple, I'd keep them pretty separate for the moment, which it sounds like you're happy to do. So I guess you have two main options to clean things up and get it working on your desired /news/ address:

  1. Delete that instance of Wordpress and re-install it at the /news/ address. So instead of the default /wp/ address that cPanel offers you can instead change this to anything. Once it's at /news/ then it's probably all good!

  2. Change your current /wp/ install to /news/ properly. You're halfway there. Once you've changed the address in your wordpress settings, you now need to move all your files from /wp/ to /news/ ... you can do this via File Manager in cPanel or via FTP. Once you've done this, make sure you log to Wordpress at the /new/wp-login.php address and then refresh permalinks by going to Settings / Permalinks and hitting 'Save Changes' which will then refresh all page addresses.

Best of luck. Let me know how you go!

| improve this answer | |
  • This is a workable solution to the problem of a WP installation not being in the root folder of a website, and the foundation for the entire site - BUT - it will cause problems IF the content uses "news" as either a taxonomy (either a category or tag) SO @henri you will want to structure all the WP content with the assumption that since it's ALL "news", use something else to further organize content if needed as categories and tags, NOT "news".....you may not think it's important (yet) to tag content but at some point the site owner may want that, so I recommend dealing with it now. – Trisha Jan 15 at 17:09
0

I went to the dashboard main options and changed the paths WordPress Address: www.mysite.com/wp/ Site Address: www.mysite.com/ or www.mysite.com/news/

You should only update the Site Address (URL). If you update the Wordpress Address (URL) then Wordpress is looking for the files in the wrong directory hence the 404.

Check out this Wordpress Page for more info.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.