1

In my WordPress website it only has the blog page. There is no home page and other pages. I want the homepage to be the blog page. When I customize the home & blog page to the same page, it prompts the following error.

enter image description here

I want the blog page URL is configured to the root path. URL has to be www.abc.com (it shows all the blogs) not www.abc.com/blog

  • 1
    Isn't it the same then as using "Your homepage displays your latest posts"? – kero Jan 8 at 13:33
  • 1
    Yeah, I think I figured it out. Rather than setting it to a Static Page, keeping the latest post made my task easier – Ramesh Jan 8 at 13:44
1

Choose 'your latest posts' as to what your homepage should show.

This will then show your latest posts on the homepage (aka your blog).

Edit: looks like you have this working now!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.