0

My client requires that a page have be located at /connect, but when accessing the built page, only a parent directory tree is displayed.

After a lot of looking around, I found that the problem was caused by the directory public_html/connect; a directory completely empty other than a .well-known folder. After deleting the folder, the page worked perfectly, but a few days later, the folder came back and broke the page again.

Any advice on where could I start looking to find the culprit for this?

1

I've usually seen a .well-known folder associated with site ownership validation for SSL certificates.

You may find the following link from Server Fault may assist in further understanding.

Maybe you can convince the Client to have a different folder name?

1
  • It was made by Let's Encrypt, so that's the string for me to pull on – Paul Elrich Jan 7 '20 at 22:55
1

It may be caused by one of your plugins; I'd check there first. Some plugins like to create folders for their own use.

I'd also check your htaccess file for the standard WP redirects (and no others that are not expected).

Finally, add this line to your htaccess in the domain root to prevent directory listings:

Options -Indexes

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.