1

I am working on theme development and using "WPBakery Page Builder" for creating pages. I am getting below mentioned error while save row as template by opening edit row settings and click on gear icon. It gives me following error::

TypeError: $ is undefined

plugins/js_composer/assets/js/dist/backend.min.js:10:82695

I am saving row as a template like this:: enter image description here

I have deactivated all the plugins except js composer and tried to save row as template but still it returns me same error.

I thought there might be an issue with mytheme so I have activated Twenty Nineteen default theme and trying to save row as a template, but I am getting save error.

Any solution? Why this is happening?

2 Answers 2

2

I was able to find a solution by doing a find and replace on this file

/wp-content/plugins/js_composer/assets/js/dist/backend.min.js $.ajax -> jQuery.ajax

Changing the $ symbol out to jQuery fixed the issue.

1
  • This issue is also resolved in latest version of visual composer plugin:: 6.1 Commented Feb 12, 2020 at 3:36
-1

Maybe u should switch using another builder, you can combine 2 plugin functionality with this :

  1. Elementor Pro (is your base/main plugin for builder).
  2. JetEngine by Crocoblock. (will be like an addon to make specific template with custom post type functionality and custom field).

Personally i just switch to both of them from WP Bakery.

1
  • 1
    Hey, I don't want to switch to another builder. I have already build my theme with js_composer. Just stuck while saving row as a template. Commented Jan 6, 2020 at 6:26

Not the answer you're looking for? Browse other questions tagged or ask your own question.