1

The problem

I cannot access my Wordpress backend anymore. I cannot do this by going to www.sitename.com/wp-admin and not by going to www.sitename.com/wp-login.php.

When I go to /wp-admin, it seems to redirect to wp-login.php and then serves my custom 404-page. /wp-login.php creates an infinite loop/redirect (or at least, that is what Firefox and Chrome tell me). The 404-page is not loaded, but the browser displays the error.

The same problem manifests itself at a subdomain (blog.sitename.com), which has a seperate wordpress installation running (but with a lot of the same plugins and the same theme, although it is used differently).

The site itself works perfectly, as does the blog.

What did I do before the problem arose?

The problem arose when I updated from EasyApache 3 to EasyApache4 and from php 5.x (not sure which one exactly, I think 5.2) to php 7.2.

Before that, I my wordpress backend worked like a charm. I am not sure anymore, but I think I also did some regular updates in the backend (plugins, themes) before updating to EA4 and php7.2.

What did I try already?

I tried the following things, and they did not provide a solution:

  • Disabling all plugins (via ftp);

  • Disabling the theme and using the standard 'twentynineteen' from wordpress. Also disabling the theme and using the standard fallback theme did not work;

  • Using a fresh .htaccess file. Also adding

    define( 'WP_HOME', 'http://example.com' ); define( 'WP_SITEURL', 'http://example.com' );

    to the existing one (and to the new one) didn't work;

  • Using a fresh wp-config file and wp-login file;

  • Checking whether file permissions are in order;

  • Downgrading php from 7.2 to 7.0 and 5.6. None worked. Downgrading to EA3 again to use the old php-version (I think it was 5.2) is not something I am keen on doing, as I needed quite some help from my hosting provider to get that working (as the updater got stuck everytime when I did it myself).

  • Resetting browser cookies and trying from a different computer.

  • I tried to error-log the problems, but a 404-error doesn't get logged I think (or it isn't a 404-error and just looks like one). I did not get any valuable clues.

I have no idea what to try next to try to regain access to my wordpress dashboards. I hope you are able to help me make a next step toward a solution!

UPDATE: I just found out that another website on the same VPS has exactly the same problem. This website has a different domain name and a different wordpress-install.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.