0

Has anyone with a WP multisite been through this process? I have created the Load Balancer and have a domain (one of the multisite sites) on an EC2 instance.

My load balancer setup looks like this:

enter image description here

Going to https://foobar.com just times out and going to https://www.foobar.com just ignores the SSL request. Is there a step I'm missing? Maybe something in httpd.conf or wp-config?

I'm sure someone has gone through something similar, it would help us all dealing with such an issue. I feel like going with WPEngine would've made much more sense than AWS for an simple WP site :(

1
  • What are you trying to accomplish? Do these URLs work without the balancers? Are you trying to put different domains on different boxes? Why? – John Dee Dec 30 '19 at 19:21
0

I am familiar with this situation ... I got out of it like this ... To begin with, in the .htaccess file that lies at the root of the site of your hosting provider - I registered it. At the very end of the file.

# END WordPress
RewriteEngine On
RewriteCond %{HTTP_HOST} ^(www\.)?yoursite\.com$ [NC]
RewriteCond %{HTTP:X-Forwarded-Proto} !=https
RewriteRule ^(.*) https://yoursite.com/$1 [R=301,L]

Then I installed the plugin: SSL Insecure Content Fixer. And set the settings in it to “Capture everything” - saved. For two weeks I drove the site with the plugin turned on. Then I deactivated the plugin. And everything became good!

Here is my working example

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.