0

Please help me, I installed WordPress locally to learn how to make sites but after my installation when I wanted to install a WordPress elementor plugin I receive this message:

To perform the requested action, WordPress needs to access your web server. Please enter your FTP credentials to proceed. If you do not remember your credentials, you should contact your web host.

i don't know how to it.

1

1 Answer 1

5

You have to add the following Line before /* That's all, stop editing! Happy publishing. */ in wp-config.php file.

define( 'FS_METHOD', 'direct' );
1
  • That solution does work, but it does not explain why and is also not the expected approach for a WP Install. This issue only surges in installs that are wrongly hardened or have other problems with file permissions. The right solution instead is to understand file permissions. Set WordPress directory and file permissions to allow your webserver's user account execute+read+write access. (Typically this means setting permissions 0775 for directories and 0664 for files.) What you are doing with define( 'FS_METHOD', 'direct' ); is de-facto telling WP to bypass all security.
    – user75665
    Oct 3, 2022 at 7:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.