I'm on a fresh install of WP and I just made a couple test posts. However, when I click on the post to view the 'single' page, it shows a 404. Furthermore, from the dashboard, when I go to the edit screen for that post and click on 'view post', I get the 404 page again. Any ideas on what can be wrong?

  • lots of things could be wrong - have you activated permalinks?
    – ptriek
    Dec 4, 2011 at 13:57
  • Yes, it is set to /%category%/%postname%/
    – John
    Dec 4, 2011 at 14:05
  • I just changed it back to the default permalinks and it worked. But then I changed it back to /%category%/%postname%/ and it's not working again. Hmm...
    – John
    Dec 4, 2011 at 14:17
  • can you post the contents of the .htaccess file in the root?
    – ptriek
    Dec 4, 2011 at 14:26
  • I also tried deactivating all of my plugins but no change unfortunately. Also, I just tried viewing a newly created page and it just goes to the home page but with the title of the page showing in the browser.
    – John
    Dec 4, 2011 at 14:27

1 Answer 1


Seems like you're not the first one having this problem, you might want to check WordPress permalinks Yahoo hosting(no .htaccess allowed)

  • Thank you. That worked. Although having index.php in the middle of the url is pissing me off.
    – John
    Dec 4, 2011 at 14:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.