2

I have a specific URL that has to be accessible without SSL, so that some old devices can access it. The reason is those old devices have the URL hardcoded.

The URL is http://domain.com/server

My .htaccess looks like this:

RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

Redirect 301 /server http://sub.domain.com/server

However, the devices can't even access the first URL because it keeps redirecting to https://domain.com/server

  • Do you have something like "automatic https redirect" setup in your hosting environment (Plesk, cPanel, etc.)? – kero Dec 18 '19 at 13:00
  • 1
    There's nothing in your .htaccess file that triggers the HTTP to HTTPS redirect. You will need to either "fix" or disable the HTTP to HTTPS redirect elsewhere in your WordPress install. Only if you disable the redirect within WP itself would you then be able to implement the redirect in .htaccess, otherwise you'll get a redirect loop. (The Redirect directive you posted is a "redirect loop" regardless, since it's unconditionally redirecting /server to /server.) – MrWhite Dec 18 '19 at 13:11
0

Your URL http://domain.com/server should work without problems. Most likely you have activated an HTTPS redirection for your website.

You should check:

  1. If you have a security or other type of plugin that forces the HTTPS redirection and deactivate the redirection. (Most likely they will edit your .htaccess file in order to force the HTTPS)
  2. Check your .htaccess file for a custom snippet that forces the HTTPS redirection
  3. Check your Hosting Settings. The HTTPS Redirection might be activated from there.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.