2

I don't know what happened but suddenly all emails under "User" are changed to [email protected] - see the below picture.

Of course, my first thought was a plugin problem, but when I disable ALL plugins then nothing changes.

Any idea what happened? The site is running under Cloudflare for months but this issue does exist since few days.

I am not aware of anything I could have changed. I am viewing the users as administrator.

enter image description here

2 Answers 2

3

This is coming from cloudflare's Email Address Obfuscation.

  1. Login to Cloudflare.
  2. Click on your domain name.
  3. Navigate to Scrape Shield
  4. Turn off Email Address Obfuscation.
  5. Purge Cloudflare Cache

2
  • +1! Very strange. Cloudflare must have had added it few days ago. I had to purge also the cache but it fixed it! Thx! Commented Dec 10, 2019 at 20:24
  • Good thought on purging cache!
    – Haris
    Commented Dec 11, 2019 at 20:06
0

Cloudflare has added Configuration Rules where you can set which pages you want to disable settings for. As Haris pointed out, Email Address Obfuscation is causing the reported issue, but with these new rules you don't have to globally disable the feature. You simply add a URI based configuration rule to disable the feature.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.