1

I have recently managed (with help from this forum ), to upload the site www.gas-spring.com .

I had the permalink setting set to plain when making the pages etc... now I want to clean them up and change them to permalink setting post name. when changing them i can only open the homepage but any other links are not working.

I have found a simple workaround, setting the permalinks to custom with /index.php/%year%/%monthnum%/%day%/%postname%/ . This cleans them up a little but still not the result I want.

Can you perhaps help me once more in solving this. So I just want to change permalinks to post name without errors off course.

Thanks in advance.

The webserver used is an Apache server, the .htaccess file is set to 644 and looks like ;

RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

1 Answer 1

0

Your Apache Write mode is not enabled. #>sudo a2enmod rewrite [sudo] password: Enabling module rewrite. To activate the new configuration, you need to run: systemctl restart apache2

It should be working after this.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.