1

my page runs on a local corporate network on a Windows 2016 server running IIS 10. PHP 7.1 WordPress 5.3

The page is used as a video platform. Videos up to 2GB can be uploaded. From our locations on the same network (upload speed 25-50Mbps) the upload works without any problems. The corresponding parameters in IIS, php.ini and wp-config.php are set correctly. The timeouts on the server and the proxies are set to 2 hrs.

The problem is:

Uploads >300MB will not complete from other locations over WAN. The connection corresponds to approx. 4Mbps uploadspeed with 130ms latency. If I simulate the upload in Chrome with these settings, I will end up with a 500 error of async-upload.php. How can I optimize the page for slow connections and latency?

I am grateful for hints!

Chrome Network Log:

Request URL: https://XXX.intra.net/wp-admin/async-upload.php Request Method: POST Status Code: 500 Internal Server Error Remote Address: 53.26.9.187:3128 Referrer Policy: strict-origin-when-cross-origin Connection: close Content-Length: 1208 Content-Type: text/html Date: Mon, 02 Dec 2019 13:40:45 GMT Server: Microsoft-IIS/10.0 X-Powered-By: XXX Accept: / Accept-Encoding: gzip, deflate, br Accept-Language: de-DE,de;q=0.9,en-US;q=0.8,en;q=0.7 Connection: keep-alive Content-Length: 518192654 Content-Type: multipart/form-data; boundary=—-WebKitFormBoundaryBYhwvYy8edwoTGJh Cookie: wordpress_sec_8e85a50d55023e68686338106663e49d=mwerbro%7C1575444406%7CmsjSnLM6HQzCeaOxjCP7aKQvqApaGGc45mHp5xiJusy%7C1632275c6b5a9f9e15fbbac0896441e90e82a263ad537b7f64fa39488e5cc72b; vchideactivationmsg_vc11=6.0.5; catAccCookies=1; wp-settings-time-134=1575035781; wp-settings-134=libraryContent%3Dbrowse%26editor%3Dhtml%26edit_element_vcUIPanelWidth%3D649%26edit_element_vcUIPanelLeft%3D923px%26edit_element_vcUIPanelTop%3D74px%26posts_list_mode%3Dlist; wordpress_logged_in_8e85a50d55023e68686338106663e49d=mwerbro%7C1575444406%7CmsjSnLM6HQzCeaOxjCP7aKQvqApaGGc45mHp5xiJusy%7Cecc5ac52a0f081c9ec834ca0a2036b2bf44482f02a5f20e1184f7fa585053bc3; wp-wpml_current_admin_language_d41d8cd98f00b204e9800998ecf8427e=de; _pk_ref.275.97ea=%5B%22%22%2C%22%22%2C1575288534%2C%22https%3A%2F%2Fsocial.intra.corpintra.net%2Finbox%22%5D; _pk_ses.275.97ea=1; wp-wpml_current_language=de; _pk_id.275.97ea=4c61b23bd9343dc7.1571816982.119.1575293156.1575288534.; ADRUM=s=1575293617793&r=https%3A%2F%2Fsocial.intra.corpintra.net%2Flogin.jspa%3F-72025792 Host: XXX.intra.net Origin: https://XXX.intra.net Referer: https://XXX.intra.net/wp-admin/media-new.php Sec-Fetch-Mode: cors Sec-Fetch-Site: same-origin User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/77.0.3865.120 Safari/537.36 name: C0008.MP4 post_id: 0 _wpnonce: 523ff9aa48 type: tab: short: 1 async-upload: (binary)

5
  • A 500 error is just your servers way of saying "something went wrong! See the error logs to find out what it is", you'll need to check your PHP error logs to find out what the actual problem is – Tom J Nowell Dec 3 '19 at 13:16
  • Hi Tom, i already checked the logs: there is always something like this: 2019-12-03 12:25:23 53.71.236.51 POST /wp-admin/async-upload.php - 80 - 53.71.100.242 Mozilla/5.0+(Windows+NT+10.0;+Win64;+x64)+AppleWebKit/537.36+(KHTML,+like+Gecko)+Chrome/77.0.3865.120+Safari/537.36 xxx.intra.net/wp-admin/media-new.php 500 0 995 329640 The Problem is, that the error only appears, when i reduce the upload speed - with full bandswith the uploads up to 2GB always workin fine – melvishb Dec 3 '19 at 13:42
  • That doesn't look like a PHP error log message, that's an Nginx/Apache access log, you need to check the PHP error log. If you don't have one or can't find it your host can enable/locate it for you. If the upload speed is what's determining the problem then I suspect this isn't really a WP issue but either a network or PHP configuration issue. Have you confirmed your increases to the PHP time limit have actually taken effect? – Tom J Nowell Dec 3 '19 at 15:26
  • The page runs, as described, on a Windows server with IIS. In fact, there was still a timeout for fastCGI not set correctly. It works now. – melvishb Dec 13 '19 at 15:11
  • if it runs on IIS but not Apache, then clearly the WordPress/PHP part is not to blame and it's the server. You don't need WordPress help and expertise, you need Apache help. Aside from that, you didn't check the PHP error logs :( – Tom J Nowell Dec 15 '19 at 12:17
0

Tom, it seems that you don´t understand. The issue is fixed now. When i checked my PHP error logs, i figured out, that in my fastcgi config a to short Timeout was set.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.