0

I have the following situation which I tried to solve by using the website and forum but unfortunately no success so far.

I am working on a new site (old still-now online) but when changing the Site Address (URL), i receive a error 404 when trying to accees the site www.gas-spring.com. enter image description here

When changing the permalink settings and saving them there is no change and I still receive the error 404. When I change the Site Address (URL) back to wordpress URL everything is working fine. I stopped plugins and clearing cache etc.. but nothing seems to work.

The .htaccess is :

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress

I really would like to receive some help in resolving this. I'm a beginner with Wordpress so maybe I have overlooked something.

I use filezilla to upload the site and the files are stored in - /home/www/public_html/wordpress

If i check the following link, https://www.gas-spring.com/wordpress/ , I can see some of the website loading but still with errors.

Filezilla / folder : enter image description here

Please inform me if you require any more info. Thanks in advace, Regards, Stefan

0

You have installed your website in public_html/wordpress so you need to move it up a directory in FTP or change your URL in the dashboard to gas-springs.com/wordpress.

The JSON error is because your Wordpress URL is HTTP and the Site URL is HTTPS.

| improve this answer | |
  • Thanks TomC, so place the complete folder > /home/www/wordpress ? And not under public-html ? – Stefan Nov 27 '19 at 11:10
  • Yes, that's right. Unless you wanted to have /wordpress/ in the URL. – TomC Nov 27 '19 at 17:48
  • Also, generally speaking, you want the Wordpress address URL and Site URL the same. And once you change it, you'll need to use gas-spring.com/wp-admin to access the admin dashboard. – TomC Nov 27 '19 at 17:51
  • Thanks TomC, apologies for not replying sooner. I have placed the entire folder to home/www/wordpress and changed siteurl and home to gas-spring.com. Unfortunately I still see no website. If i check the site in test ( w7qg742b8.homepage.t-online.de/wordpress ) it workes fines. I tried the .htaccess with RewriteRule . /wordpress/index.php [L] and RewriteRule ./index.php [L]. Is there something I am missing ? Thanks again for the replies. – Stefan Nov 28 '19 at 9:31
  • You were supposed to move the files out of the 'home/www/public_html/wordpress' directory and into the 'home/www/public_html' directory. You don't need to modify the .htaccess files. – TomC Nov 28 '19 at 9:36
1

You can also change site address in database direct. You can use below link to generate sql query to change your old url to new url. https://codepen.io/EightArmsHQ/full/nzEjI

and try below .htaccess code:

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
| improve this answer | |
  • Thanks, I have changed and updated the .htaccess file but, no success and the error 404 remains. What do you mean with ,"You can also change site address in database direct"? Where do I change this ? I can accees the PhP Myadmin. – Stefan Nov 27 '19 at 8:39
  • have you change siteurl and wordpress url? – Vimal Usadadiya Nov 27 '19 at 8:40
  • Yes, i have now changed the siteurl and wordpress url both to gas-spring.com but still the errors remains. I – Stefan Nov 27 '19 at 9:06
  • Your folder structure is in wordpress directory? – Vimal Usadadiya Nov 27 '19 at 9:41
  • My folders are uploaded to - /home/www/public_html/wordpress - See original post for filezilla file. – Stefan Nov 27 '19 at 9:47
0

I am checking links/permalinks etc... and when I edit a page and update/preview it I see the following message, "Updating failed. Error message: The response is not a valid JSON response."

I did not see this message / error before. Does it have something to do with the site not viewing properly ?

enter image description here

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.