A few days ago I have a problem. I use a 3600x2500px images. After upload image - image auto scaled to 2560x1707px and using how full size image. Example: Upload - Web_18.12.22_01@2x.jpg (3600x2400) Result - Web_18.12.22_01-2x-1-scaled.jpg (2560x1707px)

I don't understand how it makes. I don't now how change it. I just want full size image which I uploading enter image description here

  • Three things to check: your WordPress image sizes, and plugins. WP image sizes are under Settings > Medium. By default, Core will resize anything larger than the "Large" size. If that's not what's happening, try disabling plugins and uploading images after enabling one at a time to see if a specific plugin is enforcing image resizing. Finally, try switching to a default theme, such as Twenty Nineteen, to see if it's your theme.
    – WebElaine
    Nov 18, 2019 at 21:47

1 Answer 1


This behaviour was newly introduced by WordPress with version 5.3 (released on 12th of November 2019). So if you updated to that version, WP is behaving according to design. The announcement post for the new version only mentions it as

including improved large image support for uploading non-optimized, high-resolution pictures

in the section "Block Editor Improvements". More technical details can be found in trac filed under Ticket #47873. This change also brought a filter big_image_size_threshold which can be used to control this feature.

function wpse352820_big_image_size_threshold( $threshold, $imagesize, $file, $attachment_id ) {
    return 4096;
add_filter( 'big_image_size_threshold', 'wpse352820_big_image_size_threshold', 10, 4 )

Just return the value in pixels you want the pictures to have as maximum on the longer edge. If you return false in the filter, the feature should get disabled entirely, in short this can be written as follows:

add_filter( 'big_image_size_threshold', '__return_false' );

Each of these code snippets can be used by simply dropping it into your theme's functions.php or make a plugin out of it.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.