1

I'm new to WordPress. there is a problem which really freaks me out. the WordPress(v5) which my host installed for me was all in Persian; I changed the user language to English, the main interface changed to English but still live editor and plugins were in Persian. I figured out removing the language folder from wp-content solves the problem but when I upload a custom Persian theme into Wordpress everything turns back to the time before removing the language folder. also, note that changing the website language from the setting makes the website LTR which is not what I want besides telling the search engines that my website is in English which is not.

1 Answer 1

0

Welcome!

In order to change the site language, navigate to Admin dashboard-> Settings-> General and change Site Language setting.

enter image description here

3
  • "note that changing the website language from the setting makes the website LTR which is not what I want besides telling the search engines that my website is in English which is not."
    – Sepehr23
    Oct 23, 2019 at 14:58
  • Do you want front-end in Persian and Admin in English?
    – Hector
    Oct 23, 2019 at 15:51
  • 1
    yes, exactly. I want front-end in Persian and admin panel completely in English.
    – Sepehr23
    Oct 23, 2019 at 20:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.