0

There are many similar questions, but none of them have exactly the same issue as I do. Unfortunately the solutions suggested there have not fixed my issue.

After selecting a category in my Shop page, the page title turns into "Categoryname Archives - Storename". I would like to remove the "Archives" part from the title, or atleast translate it. I have not found a way to translate or remove it. I am using Loco Translate for my translation needs.

All links with examples: https://www.prindistuudio.ee/pood/ - Our Store page. https://www.prindistuudio.ee/kategooria/kruusid/ - A category named "Kruusid" is selected, the title is incorrect.

Is this a theme, SEO or some other problem? I have tried some suggestions to make changes in Yoast SEO, but for that I would need to change a certain page's SEO options. I do not know which page is handling the category selection (so https://www.prindistuudio.ee/kategooria/categoryname).

Any advice?

-1

This should be Yoast SEO related.

In your WordPress admin dashboard navigate to SEO -> Search Appearance.

Then, on the Taxonomies tab you can edit the "Archives" text (and many other strings).

1
  • I would like to see the reason for downvoting this post, because this almost certainly is the correct answer. Oct 17 '19 at 13:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.