0

I have changed default permalinks into custom structure, and I got 404 error across all of my site.

  • I assume you changed the permalinks using /wp-admin/options-permalink.php, and assuming you ticked Custom Structure option, can instead switch to Plain and see if that will restore the contents? – arvil Oct 15 '19 at 12:51
  • Can you share your custom permalink structure? There's very little information in your question, at the moment it's not possible to answer it, please provide as much detail as you possibly can! – Tom J Nowell Oct 15 '19 at 13:32
0

Try to reset your permalink structure. In your WordPress Dashboard go to Settings > Permalinks. All custom post types require additional slugs like /portfolio-item/, /destination-item/, /tour-item/, /property-item/, /listing/ etc. So you probably made a typo in your custom structure. Select an alternative permalinks structure -> Save Changes. Change it back to your standard structure and hit Save Changes once again. If you’re still getting a “404 Page Not Found” error, try other remaining methods.

permalink slug

0

You can try run "mysql" for basic default config "options-permalink.php"

UPDATE `wp_options` SET `option_value` = '' WHERE `option_name` = 'permalink_structure';

or

UPDATE `wp_options` SET `option_value` = '/%year%/%monthnum%/%day%/%postname%/' WHERE `option_name` = 'permalink_structure';

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.