0

I was wondering if anyone has had to use NTLM authentication when using wp_remote_get? Trying to authenticate using Basic but that is returning the proxy error. When I use other authenticators for different APIs that do use the Basic method, it works flawlessly!

Anyone got a solution for these?

1

In case anyone has issues like I did, I found this discussion where I added the code and instantly was authenticated. Not sure if its a Wordpress issue or a PHP one, but I feel that the ANY portion of the Wordpress authentication was getting blocked first to find the Proxy type, but timing out. Adding the code from this link worked: https://core.trac.wordpress.org/ticket/31232#comment:7

add_action( 'http_api_curl', function( $handle ) {
    curl_setopt( $handle, CURLOPT_PROXYAUTH, CURLAUTH_BASIC );
});

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.