0

I have a WordPress 5.2.3 instance that is multilingual with the help of the qtranslate-x plugin. I created a custom post type with a translatable WYSIWG field. The visual WYSIWG editor generally works, but when I display the content of the field on a page, the paragraphs are removed.

This is how it looks like in the editor:

enter image description here

This is how the page is rendered (direct link: https://crossroads-festival.org/de/film/your-turn):

enter image description here

As you can see, the paragraphs are lost when the field is displayed.

Interestingly, if I do the editing in HTML by using the text mode of the WYSIWG editor, the formatting does not get lost. However, this is not a solution, since my client wants to work with the visual editor.

I use the following plugins related to custom fields and translations. All are updated:

I don't know how or where to exactly fix this issue. Any hints are appreciated.

  • I know that I should use the newly developed qtranslate-xt plugin, but for now this is not an option for me, so a solution (maybe quick & dirty) for now, would be satisfactory for me. – beta Oct 1 '19 at 9:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.