0

I am trying to set the same page as my blog page as well as my static homepage. You might ask why i wanna do that, basically in the preview it shows me result that i am after, but i am not able to publish it as homepage and blogpage can't be same.

So, is there any way to either remove the validation so that i could publish the changes? Or To set the same page as home and blog page via db/php?

  • It doesn’t make any sense to want to do this. It suggests you’ve done something wrong somewhere. If you want your latest posts on the homepage, then you should select that option, and not have a static home page. Why do you need to do this? – Jacob Peattie Sep 26 '19 at 8:25
  • The theme that i am using allows me to display all the pages as section of my homepage (like a onepage website) sorted in the page order if i set my blog page and my home page as the same page. At least the preview shows it that way. But it doesn't let me save it. – Akshit Sep 26 '19 at 8:35
  • It sounds like something else is wrong. It doesn’t make sense that you’d need to do this to get your homepage to display a certain way. You should contact the theme author for help solving this properly. – Jacob Peattie Sep 26 '19 at 9:06
0

It seems validation was there only if I tried doing it via Appearance > Customize > Homepage settings.

However, it wasn't a hard violation if you set in via Settings > Reading.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.