0

Someone please point me to a knowldge article or information on how to setup Xdebug on XAMPP-VM Mac OS in particular.

The dev configuration:

  • XAMPP-VM
  • Mac OS Mojave 10.14.6
  • VScode with PHP debug plugin
  • Wordpress installed on XAMPP-VM

Steps tried: Followed the instructions as per this link

  1. Copied Xdebug.so to the extension folder inside XAMPP-VM & configured php.ini for xdebug values as below

    [XDebug]
    xdebug.remote_enable = 1
    xdebug.remote_autostart = 1
    xdebug.remote_connect_back=on
    zend_extension="/opt/lampp/lib/php/extensions/xdebug/xdebug.so"
    
  2. Mapped the localhost port 9000 as below

enter image description here

  1. Added debug configuration to my VScode with php debug plugin installed.
  2. I have checked phpinfo which prints with xdebug (Just to make sure the plugin is enabled)

PS: I googled around and failed to get the solution. What am i missing here?

  • Hi and welcome to the site. As this site is not really about link distribution, but about problem solving, you might want to edit the question and explain how far you got, where you got stuck and how to reproduce your problem. Thanks. – kaiser Sep 17 '19 at 21:11
  • @kaiser update the question in detail. Please help! – Nirus Sep 18 '19 at 2:35
0

After days of struggle to enable debugging, I switched to MAMP free version which was a cakewalk.

For Step by step guide please follow this blog by Josh Buchea. Has a detailed walkthrough.


Hope this helps someone stuck on Mac with Xampp-VM like i did. Switch to MAMP free version. Happy coding Wordpress PHP

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.