2

I have been experiencing a 403 error when passing parameters in the URL of a WordPress website. Has anyone else experienced this and have a solution?

The url being passed is {{website_url}}/contact-us?enquiry_type=1

However, when removing the parameter, I dont get the 403 error.

Your input would be much appreciated.

enter image description here

3
  • 2
    From a quick search, this is the Cerber Security Plugin. You'll probably have to configure that to be more lenient, or add exceptions for the query string parameter if you can, or ask them. – Rup Sep 2 '19 at 9:32
  • Thanks Rup! That worked. The plugin by default disallows parameters being passed in the URL. – Dillonsmart Sep 2 '19 at 9:39
  • @Rup can you leave that as an answer, identifying the plugin and suggesting it be disabled, and a link to their support? – Tom J Nowell Sep 2 '19 at 10:12
1

This error is generated by the Cerber Security Plugin. You can add an exception on 'Antispam' under the WP Cerber menu, 'Adjust Antispam engine', 'Query whitelist'. You probably want

{\/contact-us\?enquiry_type=\d+}

for a regular expression to match any numeric enquiry_type value. The relevant documentation is here: Configuring exceptions for the antispam engine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.