0

I changed the permalink structure to be just /%postname%/ without the index.php, I've added the required lines to the .htaccess file, Allowed override in the httpd.conf but it still doesn't work.

Any ideas why?

Here's my httpd.conf:

ServerName localhost

# forbid access to the entire filesystem by default
<Directory />
    Options None
    AllowOverride None
    <IfModule !mod_access_compat.c>
        Require all denied
    </IfModule>
    <IfModule mod_access_compat.c>
        Order deny,allow
        Deny from all
    </IfModule>
</Directory>

<Directory /srv/www/htdocs/>
        AllowOverride All
</Directory>

# use .htaccess files for overriding,
AccessFileName .htaccess
# and never show them
<Files ~ "^\.ht">
    <IfModule !mod_access_compat.c>
        Require all denied
    </IfModule>
    <IfModule mod_access_compat.c>
        Order allow,deny
        Deny from all
    </IfModule>
</Files>

And the .htaccess file:

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress
4
  • Caching may be an issue. Have you tried clearing any server/plugin caches and trying an Incognito window or clearing your own browser cache?
    – WebElaine
    Aug 27, 2019 at 13:54
  • What do you mean "doesn't work"?
    – Max Yudin
    Aug 27, 2019 at 14:08
  • By doesn't work I mean that if I try to publish a new post or page an error pops up saying "Publishing failed" Aug 27, 2019 at 14:18
  • Did you restart Apache after making changes to the server config? Is mod_rewrite enabled? Please post the contents of your .htaccess file.
    – MrWhite
    Aug 27, 2019 at 14:27

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.