0

the website that I am working has been developed by a web designing company. i see that they disabled the home page slug editor but the rest of the pages has the edit option. Now I am trying to add a Chinese translation and I am a bit confused about the slug missing only in the home page.

enter image description here enter image description here

  • That's the usual behaviour of WordPress. The home page doesn't have slug as it is the main landing page. The translation slug (/en, /ch) is held by the translation plugin. You must create a new translation domain on the translation plugin settings. Which plugin do you have to handle the translations? – Carlos Faria Aug 7 at 6:59
  • Hi Carlos Faria, many thanks for the information. WPML is the plugin used for the translation, last time what happened was that when I try to add the Chinese translation, the home page link automatically changed and the title of the page added to the link, I also happened to see the slug editor but I couldn't edit the link to bring back to normal. The problem was that, the news page became the homepage, whenever someone clicks on the homepage they see the news page instead. so I had to restore the site with the backup. it would be very helpful if you can share some knowledge about it – Lal Prasanth Aug 7 at 7:43
  • Go to settings/reading and change the main page to the one you want to be the homepage. – Carlos Faria Aug 7 at 10:10
  • thanks for your help. it's sorted now – Lal Prasanth Aug 12 at 6:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.