0

When I save "https://example.com" in General Settings as my Site & Wordpress URL, it gets replaced by "//example.com".

To analyze the problem, I checked the Wordpress database, but 'WP_HOME' and "WP_SITEURL" are correctly stored as "https://example.com".

Actually, this is not a big problem, but Yoast SEO also shows my canonical URL as "//example.com". So I need to fix that problem ...

  • WordPress doesn't do this on its own. It must be a plugin or a theme. The first step in trying to diagnose this would be to turn off all plugins and switch to a default theme, then start turning plugins back on, one by one, till you find the culprit. If none of your plugins are to blame, then it is probably the theme you were using. – Pat J Jul 28 at 0:43
  • 1
    thanks a lot, you've been right. A plugin was responsible for that problem. If you put this comment as an answer, I will mark it as a valid answer. – rob_87 Jul 28 at 9:40
  • There, done. (I find, a lot of the time, I can debug a problem by turning off all plugins and then bringing them back one at a time.) – Pat J Jul 28 at 15:09
0

WordPress doesn't do this on its own. It must be a plugin or a theme. The first step in trying to diagnose this would be to turn off all plugins and switch to a default theme, then start turning plugins back on, one by one, till you find the culprit. If none of your plugins are to blame, then it is probably the theme you were using.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.