0

I am working on wordpress site with facetwp plugin. It already show the facet filter properly. When I filter it by checked the checkbox (on left sidebar) it will show the results. But when I uncheck that then it's not back to reload the content of wordpress (in this case I use AZ Listing plugin).

How to revert back to showing the old content when uncheck the facetwp? This is the link: http://korexindo.com/k-market/

1 Answer 1

1

I think the "initial" state being a shortcode is the root of your issue.

I'm making a few assumptions to what your setup looks like:

  1. You have the [a-z-listing] shortcode as your "default" state for the FacetWP settings on this page.
  2. FacetWP and AZ Listings are not integrated (I don't believe they are officially).

Here is a breakdown of events (given the assumptions above):

  1. FacetWP does an initial load and executes do_shortcode somewhere in order to render [a-z-listing].
  2. Upon filtering something with FacetWP, the shortcode html is completely deleted from the DOM. This means that we cannot get it back unless we somehow re-render the default state (page refresh?).
  3. Unchecking the filter does not resolve back to the initial state because FacetWP does not execute do_shortcode again.

Here is an animated GIF of a-z listings being replaced by the Facetwp results template completely: https://i.sstatic.net/pSaXU.jpg

While this may not be the answer you're looking for, it may point you in the right direction. I would look into the following resources:

Not the answer you're looking for? Browse other questions tagged or ask your own question.