I tried to commit the changes to the “Filenames to latin” plugin and got the SVN error.

The error message:

Error: Commit failed (details follow): Error: Commit blocked by pre-commit hook (exit code 1) with output: Error: [Error output could not be translated from the native locale to UTF-8.] Error: This error was generated by a custom hook script on the Subversion server. Error: Please contact your server administrator for help with resolving this issue.

The latest code for the plugin I had issues with is in the GIT repo.

Does anyone know how can I solve this issue?

Thank you in advance.

  • 1
    You should contact plugins@wordpress.org if you're having trouble with the repo. – Jacob Peattie Jul 9 '19 at 12:28
  • Are you working on Windows? It might be worth trying to commit on something that's UTF-8 native e.g. a Linux VM or a Mac, if you have access to one (e.g. on one of your VMs where you host WordPress?) Get a fresh checkout from Git there and then try and commit to SVN. I'd guess the problem an odd interaction with the Windows version of SVN, so a Git Bash console on Windows probably wouldn't work unless you can get SVN built for it too. WSL might work, again if you can get native versions of Git and SVN inside that. – Rup Jul 13 '19 at 9:31
  • @Rup Yes, I am working on Windows and unfortunately dont have access to Linux or Mac right now. And thank you for the suggestion. I will think about this option too. – webvitaly Jul 13 '19 at 20:25

Wow, your plugin is very useful. #@^%$@ -> rysunok. That's so amazing!!!

About your problem, I guess you copied and pasted the special characters from other into your php files, so it caused this error.

My solution:

Try opening the file in Notepad++, click on Encoding tab at top menu, you will see the current encoding of your file, choose Encode in UTF-8 to convert them into UTF-8 format.

Repeat the same action to all your files. Commit your WP project to see the result.

  • Thank you very much @Jamy for your reply. The issue was with missing comma actually. And your solution was helpful to debug it. – webvitaly Jul 15 '19 at 4:16

Finally solved the issue. The problem was with the missing comma in the key-value array. It took me some time to found it. The error message was misleading: "Error output could not be translated from the native locale to UTF-8." WordPress SVN repository is doing code analyse before using pre-commit hook. I hope this will be useful for someone else too.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.