0

Forgot password does not work, getting an email with a link but after clicking the link it's asking to fill email in again instead of being able to fill in a new password.

I am using the WooCommerce page for resetting my password. And after filling in the email, it does send the email which I receive correctly. Although after clicking the reset link it shows me the same form again, which is asking to fill in my email/username and it should be showing a field to pick a new password. It does append the /?show-reset-form=true to the URL

WooCommerce lost password reset flow not working with SendGrid (redirect loop)

I did found above thread, I got the same problem and I use Mailgun for my mail. I tried turning of link tracking but the issue still persists while the links are back to normal again and it also gives the KEY and ID like it should.

  • The fact that you're getting the ?show-reset-form=true makes me think this isn't the root problem, but does the link in the email match the formatting I mention in #3 here? If the link seems ok, can you check (with your browser's developer tools panel) that a cookie starting with wp-resetpass is being set in your browser? If it's not, I suspect caching or security plugins are preventing it from being sent, or browser settings are blocking it. – Dan Wich Jul 8 at 17:51
  • @DanWich Thank you for your reply! I have tested it and the cookie is not being set, although I have also tried disabling all plugins and themes including my caching and it still didnt work. I am also using incognito so I doubt that my browser is blocking it – fkkm1999 Jul 9 at 11:33
  • Is it possible your host is doing some caching that's ignoring non-whitelisted cookies? I think WP Engine is one example that needs an exemption for cookies starting with wp-resetpass. You can sometimes see headers in the developer tools that show whether there was a cache "miss" or "hit", where you only want to be seeing "miss" during the reset. – Dan Wich Jul 9 at 23:04
0

I got same issue a few days ago. I figured out that the problem was in my theme. How did I knew that. I disabled all the plugins and tried again but the problem still there so I connected my hosting to help me and they just whitelisted my IP-addresse in Security Mode but the problem still there so I switched to the Twenty Fifteen theme and it's worked. So the problem was in my theme. I connected the theme author and they said they will release an update to it.

  • Thank you for your answer. I just tried applying WP default theme AND disabling all the plugins but the problem still persists. – fkkm1999 Jul 9 at 10:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.