0

I'm using Centos Web Panel with Nginx reverse proxy to apache to run my WP installs. I've installed Rocket Nginx for my config and it works great for the most part, however, i'm not able to upload through the wp-admin area because I'm getting a permissions error on wp-content.

wp-content's current perms are: directories: useraccount:usergroup 0755 and files: useraccount:usergroup 0644

I've tried using useraccount:nobody and nginx:nginx to no avail and I've tried both those combinations with 775,777 (directories) & 664, 666 (files) and still can't get it to work.

I'm not terribly familiar with nginx yet so any help would be appreciated.

Also, I should note that this is a site from another server that I've transferred, but there was no caching plugins installed previously and I've both run CWP's Fix Permissions and variations of:

[public_html]# find ./ -type d -exec chmod 755 {} \;
[public_html]# find ./ -type f -exec chmod 644 {} \;
[public_html]# chown -R {user}:{group} ./* as specified above

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.