-1

I'm not sure if this is default behaviour, at least for the theme I am using, but when I go to my blog, all of the posts just stream down the page.

So, how do I make it so that when I scroll through it, only the title of the post, as well as an excerpt, if one is provided, will show up? In the case that an excerpt is not available, is it possible to set something up to display the first X% of a post, either for that particular post or for all posts?

  • Where do I put this line of code you posted in the previous line? I went to /blog/wp-content/themes/twentyseventeen and saw a bunch of files and some folders, one of which is called TemplateParts. – HeavenlyHarmony Jul 1 at 12:05
  • Please just ignore that comment and try this. – Sally CJ Jul 1 at 14:34
  • I was able to get it to work, although the child theme was missing a template and index file. Anyhow, I discovered that I had a Twenty-nineteen theme, so I upgraded to that. The directories and PHP files are a lot different, so I couldn't paste the code in your MD file in this one. This post from WordPress Forum didn't help much. – HeavenlyHarmony Jul 1 at 18:25
  • In Twenty Nineteen, the template part is located in template-parts/content/content.php. Check the updated gist. – Sally CJ Jul 1 at 23:19
0

Simple setting: look at Admin, Settings, Reading. Change the "Blog pages show at most" value (count).

Then look at your Theme Customizations for a setting to show full posts or excerpts. If you don't put a manual excerpt on the post editing page, then the theme will grab the first xx words (depending on the settings in Theme Customizations). Most themes have a way to specify excerpts or full posts on the home page.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.