1

I wonder if you can help me, please?

I have the following problem with a permalink.

I have tried to change the permalink for the following link from https://impactgoals.com/what-are-impact-goals-2/ to https://impactgoals.com/what-are-impact-goals/

by going into page on the Dashboard and editing it there. Each time that I save it, WP changes it back to what-are-impact-goals-2. I can change it to other things (eg impact-goals) but not to what-are-impact-goals.

I searched for help and one recommendation is to empty trash. I have no pages in trash.

Other is to check Media. Again, no similar link.

https://impactgoals.com/what-are-impact-goals/ takes me to my homepage.

I presume that WP has what-are-impact-goals recorded somewhere. Any ideas?

  • It does sound like something is trashed. If that's not the case you could search the wp_posts database table for the what-are-impact-goals slug, it's likely you'll find an old post there that hasn't been removed for some reason. – bigdaveygeorge Jun 29 at 8:42
  • Hi, thanks for coming back on this. Trash isn't showing in Pages, so I assume it is empty. Is there somewhere else you would suggest looking? – Berni Jun 29 at 8:55
  • How do I find the wp_posts database table? – Berni Jun 29 at 8:56
  • 2
    are you sure there isn't a post rather than a page that is trashed? To view that table you need to look in the database, this is generally done through your hosting control panel using something like phpMyAdmin. However the issue your describing isn't something that generally occurs and WordPress should deal with automatically. It's very likely a page/post still exists with that "slug". – bigdaveygeorge Jun 29 at 9:04
  • @Berni Could it be that the slug of your current front page (or some other non-trashed page) is what-are-impact-goals? Click Quick edit of the front page on your Pages list and change the slug if necessary. – Antti Koskinen Jun 29 at 14:31
0

May be the main reason of this issue is that the WordPress finds that this URLs already assign to any post which exists in database. so You have to check permalinks of the every pages/post or attachments are not using that permalink. It could be in publish, drafts or trash as well.

or you can find in wp_posts table in database from phpmyadmin. you can search using :

wp_posts > search tab > "post_name" operator LIKE%..%  value "what-are-impact-goals"

or you can fire SQL query in SQL tab:

SELECT * FROM `wp_posts` WHERE `post_name` LIKE '%what-are-impact-goals%'

Check there is permalink already exists or not. then after you can take action.

  • Brilliant. You've taught me loads, thank you. I've found it through the wp_posts table. It is associated with my home page as @Antti suggested. Problem is my home page ("I'm Home") doesn't show a slug in the Permalink. It simply gives my web address ("Permalink: impactgoals.com/"). Any thoughts about how it is hiding the "what-are-impact-goals" slug? – Berni Jul 2 at 22:00
  • I've sorted it - I just needed to edit the entry in the wp-posts table. Thanks loads for your help. – Berni Jul 2 at 22:21
  • @Berni - to answer your questions about how/why the slug was 'hidden', that happens when you select a Page to be your 'home' page under Settings>Reading, if you were to select a different Page, then the original one would once again show the full URL (permalink). That's done to allow you the freedom to change your 'home' page as you need to without worrying about its indexing in the search engines. – Trisha Jul 3 at 16:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.