0

I have a Centos Web Panel hosting and a new WordPress file. I wanted to migrate all of my local WordPress files to the live server so I installed All-in-one WP Migration. Unfortunately it can only receive 2 MB of data. The total data to be imported is around 297 MB. So I tried increasing the upload size in .htaccess but every time I make a change, it prompts me with the error:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator at webmaster@sample.em-n-em.us to inform them of the time this error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log.

This is the tutorial I tried:
https://help.servmask.com/2018/10/27/how-to-increase-maximum-upload-file-size-in-wordpress/

How can I fix this problem?

  • How is PHP installed on your server? You can only configure PHP in .htaccess if PHP is installed as an Apache module. – MrWhite Jun 24 at 9:52
0

Without seeing your htaccess file (all of it), you could be placing the commands in an improper spot.

Or, your hosting provider may not allow those commands.

Best bet for increasing the upload size it to contact your hosting support and ask how it should be done. It may be a setting that only they can make.

You can check the default and current settings by making a page template (easiest) and including this line in the middle to replace the entire loop.

phpinfo();die();

The first commadn will show all of the PHP settings, the second command will 'die' the page, which is OK, because it's just a test page.

There may also be a phpinfo-type command available on your hosting's cPanel.

0

For increase upload file size from htaccess use this below codes

php_value upload_max_filesize 128M
php_value post_max_size 128M
php_value max_execution_time 300
php_value max_input_time 300

Also plugin is available Increase Maximum Upload File Size you can find this plugin from WordPress repository.

0

You can only configure PHP in .htaccess if PHP is installed as an Apache module, otherwise (on CGI/FastCGI) you will need to use a .user.ini file (sometimes this filename can vary per host). And then use the equivalent INI config, for example:

upload_max_filesize = 340M
post_max_size = 128M
memory_limit = 512M
max_execution_time = 300
max_input_time = 300

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.