0

I wanted to show you this issue. This is happening first time with me in my 10 years career, I have cloned many sites to another domain in past but this is for the first time when I do not see the "site URL and home options" under Wp_Options (phpmyadmin)

This is the domain name which I cloned

https://13cabsonline.com.au

and this is the destination domain

https://silverservice.sydney/

I have downloaded and restored files via Backup Widget. Uploaded the file manager + databases and connected the databases with a user too.

But the issue is that I am not able to find the options under Wp_Options in phpmyadmin.

For example: A normal look of wp_options is like this http://prnt.sc/o1724k but I see this https://prnt.sc/o172as

Can you please have a look at it as there is no video or blog about it on the internet. This is strange to me.

  • might be your database not imported fully on phpmyadmin kindly double check your SQL file with the editor is wp_options table exists or not. – Evince Development Jun 13 at 6:47
  • Have a look at your next page (or 2) in the wp_options ;-) – Monkey Puzzle Jun 13 at 6:48
1

Check wp-config.php. It's possible to define these values there, in which case they won't be available as settings, which means they won't be saved in the database.

It is possible to set the site URL manually in the wp-config.php file.

Add these two lines to your wp-config.php, where “example.com” is the correct location of your site.

define( 'WP_HOME', 'http://example.com' );
define( 'WP_SITEURL', 'http://example.com' );

This is not necessarily the best fix, it’s just hard-coding the values into the site itself. You won’t be able to edit them on the General settings page anymore when using this method.

https://wordpress.org/support/article/changing-the-site-url/#edit-wp-config-php

If this was done on the original site, the corresponding values won't exist in wp_options. The solution would be to either change the values in wp-config.php, or remove these lines from wp-config.php and then insert the desired values into wp_options manually.

  • Thank you, i actually, copy pasted that code as well, but that did not solve the issue. But i went inside the phpmyadmin and clicked on the wp_options and then clicked on the search bar, i searched siteurl and home and i found both values. Actually for someone unknown reason, siteurl and home was hidden. What have i done now? I have deleted the whole cpanel, and created a cpanel again for the site silverservice.sydney I have added the new user and connected the wp_config.php with the database. But still i am getting this error --> Error establishing a database connection – Daljit Singh Khalsa Jun 13 at 9:12
0

I got it solved. I deleted the cpanel and recreated cpanel again in my hosting. Then i just restore everything. It worked.

I am going to add a screenshot here which will help others to find the hidden siteurl and home field --> enter image description here

enter image description here

enter image description here

You can search siteurl as well to edit the hidden field.

My official website is this --> https://www.khalsa-website-designers.net/

You can contact me, if you are having the same issue, and want me to help you. I will dafinatly help you for free.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.